Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Lower than expected/bursty performance

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Jimzamjimmyy

Newbie
Joined
Aug 14, 2019
Messages
3
Hello! Thanks for reading my post!
I have been experimenting with freenas for a year now and this is still my first system. My issue is that really anything I move to my pool doesn't fully saturate even my 1gb ethernet link. I'm using SMB. Iperf test looks like everything is fine (around 110MB/s result). I ran dd if=/dev/zero of=/mnt/MainPool/testfile bs=4M count=10000 (compression disabled) and got 254 931 230 bytes/second as result and then I ran dd again from remote machine which gave only 44.0 MB/s. I compared the result to this thread and then I found this amazon review with benchmarks with bit better hardware, but way better performance. I can hear that my hard drives are working only in bursts when ran from remote machine and I here is a image from the remote machine while it was running dd to freenas:
bursting.png


My hardware:
  • 8x Hitachi Ultrastar 4TB 7.2K SAS Hard Drive HUS724040ALS641 B26927 (Configured into single RAIDZ2 pool)
  • Dell Perc H310 LSI 9240-8i M1015 (pcie passtrough)
  • Running as 4 core Xeon E5-2667 v2 ESXi vm
  • 33.77 GB ram
  • no cache drive
So am I really pushing something to the limits or could it be a misconfiguration I haven't yet found out?
 

Jimzamjimmyy

Newbie
Joined
Aug 14, 2019
Messages
3
Okay, it is likely issue with my Fedora SMB access since my MacBook has been pushing constant 120MB/s to the freenas share
 
Top