Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED Jail Unable to find template!

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
For some reason, I cannot add a new blank jail to FreeNAS. I've pinged google.com and the jails repository as below but keep getting the "Unable to find template!" error.
Code:
[root@server ~]# ping -c 5 gogle.com
PING gogle.com (74.125.20.105): 56 data bytes
64 bytes from 74.125.20.105: icmp_seq=0 ttl=43 time=47.377 ms
64 bytes from 74.125.20.105: icmp_seq=1 ttl=43 time=39.883 ms
64 bytes from 74.125.20.105: icmp_seq=2 ttl=43 time=48.869 ms
64 bytes from 74.125.20.105: icmp_seq=3 ttl=43 time=40.606 ms
64 bytes from 74.125.20.105: icmp_seq=4 ttl=43 time=49.143 ms

--- gogle.com ping statistics ---
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 39.883/45.176/49.143/4.077 ms
[root@server ~]# ping -c 5 https://download.freenas.org/jails/9.3/x64
ping: cannot resolve https://download.freenas.org/jails/9.3/x64: Unknown server
error
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,946
your ping command seems wrong. you cant ping a URL just a hostname/IP
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Understood. However, I still don't get a response if I ping download.freenas
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,946
do you mean download.freenas.org?
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
do you mean download.freenas?
Yes. For some reason, I keep getting an error stating there appears to be a URL in your post, and I cannot complete the post with the full URL. Not sure why it's doing this today.
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,946
Yes. For some reason, I keep getting an error stating there appears to be a URL in your post, and I cannot complete the post with the full URL. Not sure why it's doing this today.
ahh, I see.
hmm I don't get a ping response either, so I think they just disabled that. but the address does resolve for me. not sure what else you can check.

I did notice your earlier URL was HTTPS. I've always used http for my repo URL, not sure if this has changed recently.
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Am I understanding correctly in that you cannot ping download.freenas from shell either? If that is the case, I wonder what is going on and how long it will be down. If it's down for a substantial period of time, is there an alternative download site?
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,946
Am I understanding correctly in that you cannot ping download.freenas from shell either? If that is the case, I wonder what is going on and how long it will be down. If it's down for a substantial period of time, is there an alternative download site?
no that's not what I meant to say. I'm just saying the server at download.freenas.org doesn't respond to ping.
a better test would be to 'fetch' a URL from it.
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
I see what you're saying. If that's the case, then why can I not compile a new jail from the download URL?
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,946
I see what you're saying. If that's the case, then why can I not compile a new jail from the download URL?
you aren't compiling it, just downloading it.
I'm not sure why it doesnt work. hopefully someone else who knows could answer.
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Got it. Thanks again for your assistance Joshua!
 

pirateghost

Unintelligible Geek
Joined
Feb 29, 2012
Messages
4,219
You can turn off ICMP response on servers which is what it appears they do for that URL. You can browse to it which means it isn't down.
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
I see. So why can I not download the latest jail?
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Is anyone else having this problem?
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Here's some of the commands that I'm getting after I try and install a new blank jail. Hopefully someone smarter than me can make sense of it.
Code:
Aug 12 20:10:06 server manage.py: [common.pipesubr:70] Popen()ing: /sbin/ping -q -t 2 -o 192.168.1.119
Aug 12 20:10:21 server smbd[47937]:  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsmatchname: host name/name mismatch: 192.168.1.1 != (NULL)
Aug 12 20:10:21 server smbd[47937]: [2015/08/12 20:10:21.314096,  0] ../source3/lib/util_sock.c:1199(get_remote_hostname)
Aug 12 20:10:21 server smbd[47937]:  matchname failed on 192.168.1.1
Aug 12 20:10:26 server manage.py: [common.pipesubr:70] Popen()ing: /sbin/ping -q -t 2 -o 192.168.1.119
Aug 12 20:10:42 server manage.py: [common.pipesubr:70] Popen()ing: /sbin/ping -q -t 2 -o 192.168.1.119
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Is there a place where I can look through an error log or something?
 

Darren Myers

Neophyte Sage
Joined
Oct 2, 2014
Messages
926
Are you on the latest FreeNAS build? There was an issue a while ago i ran into where i couldnt find templates either, the latest build resolves that, or at least the latest build when i had the issue resolved it
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
I've been keeping up on the updates as they come out and do not have any pending updates either.

The current build I'm running is: FreeNAS-9.3-STABLE-201506292130
 

sdgenxr

Member
Joined
Sep 4, 2014
Messages
125
Status
Not open for further replies.
Top