Issue when trying to copy snapshot data through "previous versions"

Status
Not open for further replies.

Eniqmatic

Explorer
Joined
Mar 24, 2015
Messages
72
Hi all,

We are having an issue that has appeared since updating from 11.0 U3 to 11.1. I am unsure whether this is a FreeNAS issue or if its an issue on the Windows side, cause you know, Windows.

The situation is this:
  1. Go into the FreeNAS SMB share using windows explorer, right click, properties and choose previous version. Open the time period I am looking for.
  2. Once there, I select the file, then copy and paste it to a location on the Windows Server.
  3. Error message appears saying "You need permission from "Some user" in order to modify this file". I am that user it is asking for.
  4. I notice the attached error in the log file at /var/log/samba4/log.smbd
This is on a Server 2008 R2 that we get the errors mentioned in step 3 and 4.

However there are two work arounds:
  • It works using a copy command through the Windows command prompt and copying the URL from explorer, on the same server.
  • It works from Server 2012 R2 or Windows 10.
The fact that it works on Server 2012 is odd, but so is the fact it works through the command prompt and not explorer. I was definitely leaning towards it being a Windows issue along the lines of SMB version (SMB1.0) because I noticed that in 11.1 update that the "minimum/maximum protocol level" drop downs were removed. However I tried setting "server min protocol = SMB2.0" in the share's auxiliary parameters box but this didn't make a difference. Also seeing errors in the Samba log file also make me question which side it is.

I have also filed a bug ticket here: https://redmine.ixsystems.com/issues/27857

I hope that makes sense, any questions please let me know!

Thanks in advance!
 

Attachments

  • SMB Bug freenas message.PNG
    SMB Bug freenas message.PNG
    18.9 KB · Views: 470
  • SMB Bug windows message.PNG
    SMB Bug windows message.PNG
    10.9 KB · Views: 454

Eniqmatic

Explorer
Joined
Mar 24, 2015
Messages
72
Try removing the zfs_space vfs object from the [edinburgh_data_jcca_docs] share.

Hey Anodos,

That worked! Any reason why/what changed to cause that? I've re-enabled it for now as wasn't sure what implications it could have on other things (please enlighten me :D) but I am away to see if I research what it does - I have no idea currently!

Thanks again
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
9,554
Hey Anodos,

That worked! Any reason why/what changed to cause that? I've re-enabled it for now as wasn't sure what implications it could have on other things (please enlighten me :D) but I am away to see if I research what it does - I have no idea currently!

Thanks again

There were some changes in Samba's VFS layer that required some changes in this VFS module. zfs_space gets the used/available/etc from ZFS rather than using samba's internal dfree.

This should be fixed in 11.1-U1. If you don't mind, can you upgrade to latest version and try to reproduce?
 

Eniqmatic

Explorer
Joined
Mar 24, 2015
Messages
72
There were some changes in Samba's VFS layer that required some changes in this VFS module. zfs_space gets the used/available/etc from ZFS rather than using samba's internal dfree.

This should be fixed in 11.1-U1. If you don't mind, can you upgrade to latest version and try to reproduce?
Thank you for the explanation! I will just upgrade now and let you know the results!
 

Eniqmatic

Explorer
Joined
Mar 24, 2015
Messages
72
There were some changes in Samba's VFS layer that required some changes in this VFS module. zfs_space gets the used/available/etc from ZFS rather than using samba's internal dfree.

This should be fixed in 11.1-U1. If you don't mind, can you upgrade to latest version and try to reproduce?
Unfortunately the update does not fix my issue, is there anything I need to do after upgrading?
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
9,554
Unfortunately the update does not fix my issue, is there anything I need to do after upgrading?

Excellent. I think you've found a bug in zfs_space or shadow_copy2. Under services->smb set log level to "debug", reproduce the problem, generate a debug (system->advanced->save debug), then attach it to your bug ticket. :)
 

Eniqmatic

Explorer
Joined
Mar 24, 2015
Messages
72
Excellent. I think you've found a bug in zfs_space or shadow_copy2. Under services->smb set log level to "debug", reproduce the problem, generate a debug (system->advanced->save debug), then attach it to your bug ticket. :)
Hey Anodos,

Thanks for that, I've uploaded it to the ticket now. Thanks for your help.
 
Status
Not open for further replies.
Top