iGPU not detected but motherboard integrated graphics working


Jul 19, 2022
Hello Truenas community, I've just finished assembling a NAS server running Truenas Scale. My goal is to run multiple VMs, including one that I'd like the integrated graphics from my CPU to be passthrough to that VM.

My hardware:
- Supermicro X11SCL-F
- CORE I3-8300 3.70GHZ 8M LGA1151

When creating a VM, I can select the GPU to be passthrough to the VM. I unfortunately only see the onboard one from the motherboard (ASPEED Graphics Family), not the one from the CPU.

Things I've tried/command run to troubleshoot:
- When looking in the bios, I do not see an option to enable it. I followed this https://ahelpme.com/servers/supermicro/enable-internal-graphics-in-supermicro-servers/ and the "Graphics Configuration" option is not there.
- Tried this https://github.com/intel/intel-device-plugins-for-kubernetes/blob/main/cmd/gpu_plugin/README.md however I do end up in the error state, e.g. "0/1 nodes are available: 1 Insufficient gpu.intel.com/i915"
root@truenas[~]# ls -la /dev/dri                                                                                                               
total 0
drwxr-xr-x  3 root root      80 Jul 19 14:54 .
drwxr-xr-x 20 root root    3660 Jul 19 14:58 ..
drwxr-xr-x  2 root root      60 Jul 19 14:54 by-path
crw-rw----  1 root video 226, 0 Jul 19 14:54 card0

root@truenas[~]# ls -la /sys/class/drm/card?
lrwxrwxrwx 1 root root 0 Jul 19 14:54 /sys/class/drm/card0 -> ../../devices/pci0000:00/0000:00:1c.1/0000:07:00.0/0000:08:00.0/drm/card0

root@truenas[~]# lshw -c video
       description: VGA compatible controller
       product: ASPEED Graphics Family
       vendor: ASPEED Technology, Inc.
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 41
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi vga_controller cap_list rom
       configuration: driver=ast latency=0
       resources: irq:17 memory:90000000-90ffffff memory:91000000-9101ffff ioport:3000(size=128) memory:c0000-dffff#

^ This one is the one from the motherboard. The iGPU one was not detected.

So I'm stuck. It doesn't seem the system is able to see my iGPU, nor does the BIOS? How is that possible? Is somehow the motherboard the issue?


Mar 9, 2013
I'm having the same issue with an i7-12700. Did you ever find a resolution?


Jan 18, 2024
If anyone finds themselves here in the future one of the big issues I hit was differences when a monitor was plugged in during boot.

I have a W680 i7-12700k and to get the integrated graphics working on reboots I had to either have a monitor plugged in at boot time or use an HDMI dummy plug (cheap options on Amazon).

I was getting into issues trying to run it headless, seems the integrated graphics might not be recognized unless there's an output available. Hope this helps someone!