Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

How to set permissions ('Apply Permissions Recursively' is not saving)

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

dun

Neophyte
Joined
Mar 31, 2020
Messages
8
Syncthing has no permissions to write to pools after installation. Because I didn't find a documentation on how to setup Syncthing on FreeNAS I followed the only up to date resource for this, a YouTube video. Btw is that really the only up to date resource on how to setup Syncthing on FreeNAS? I couldn't find anything else.
So according to the video I should create a user for the UID 983, create a DataSet and edit its permissions so the owner is the created user. Afterwards I have to stop the Syncthing jail, edit it's mountpoint, pick the DataSet's path as source and a path within the Syncthing jail as destination and then start Syncthing again. Afterwards Syncthing should be able to write into the DataSet.

I followed those steps but I still can't write into the DataSet.Failed to create folder root directory mkdir /mnt/Main: permission denied
I think the reason for it is that the option Apply Permissions Recursively is not being actually applied. If I tick that option I can save the permissions but if I edit it again the option is not ticked anymore. Could that be the reason for the error thrown by Syncthing?
 

sretalla

Dedicated Sage
Joined
Jan 1, 2016
Messages
3,067
It's a one-time setting, it's not meant to stay ticked.
 

dun

Neophyte
Joined
Mar 31, 2020
Messages
8
It's a one-time setting, it's not meant to stay ticked.
Ok good to know.

I also found the mistake I kept doing. In Syncthing I have to choose the path of the destination of the mount point and not the actual destination of the DataSet.
 
Top