Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

extending SNMP (getting crazy)

Status
Not open for further replies.

crester

Newbie
Joined
Apr 23, 2016
Messages
2
Hello.

FreeNAS-9.10-STABLE-201604111739 (896cc83)

I am trying to extend SNMP to process some bash scripts.
Begining from scratch I am trying a very simple script:

in Services -> SNMP ->Auxiliary parameters

extend test/bin/echo hello

ssh to server and:

Code:
[root@freenas] ~/bin# snmpwalk -v2c -c public localhost nsExtendOutput1
NET-SNMP-EXTEND-MIB::nsExtendOutput1Line."test" = STRING: hello
NET-SNMP-EXTEND-MIB::nsExtendOutputFull."test" = STRING: hello
NET-SNMP-EXTEND-MIB::nsExtendOutNumLines."test" = INTEGER: 1
NET-SNMP-EXTEND-MIB::nsExtendResult."test" = INTEGER: 0


looks fine

Code:
[root@freenas] ~/bin# snmptranslate -On NET-SNMP-EXTEND-MIB::nsExtendOutput1Line.\"test\"
.1.3.6.1.4.1.8072.1.3.2.3.1.1.4.116.101.115.116


looks fine,

but

Code:
[root@freenas] ~/bin# snmpget -v2c -c public localhost test
IF-MIB::ifTestGroup = No Such Object available on this agent at this OID


[root@freenas] ~/bin# snmpget -v2c -c public localhost NET-SNMP-EXTEND-MIB::test
NET-SNMP-EXTEND-MIB::test: Unknown Object Identifier



I am almost sure it is a simple solution, but I have been working for 4 hours against this and I am unable to locate the problem.

Some help will be appreciated, thanks
 

jgreco

Resident Grinch
Moderator
Joined
May 29, 2011
Messages
13,189
mod note: Evicted from installation forum, nothing to do with installation.

I'll note that it is sometimes clearer what is going on if you instead just use the numeric OID's when doing your initial "does it work" testing, rather than heaping the translation layer on as well.
 
Status
Not open for further replies.
Top