• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

Error when setting up replication Task

bent98

Contributor
Joined
Jul 21, 2017
Messages
171
I was hoping someone can help here. I have two on prem TrueNAS-13.0-U6.1 servers.. I am trying to do a replication snap shot from main server to my newly built back up server. I configured the snapshot to run every day and have configured the replication task as a push over NetCat SSH. I am not using encryption and both servers are on the same network. Thanks to Constantin for trying to help me.


My Main server that will be pushing the data has 1 large pool and SMB shares to each folder on the drive. I do not have any data sets created on the pool other than the default ones (Jail, IO Cage) I tried pushing the whole pool and also tried just push a individual data set I created called "test" and each attempt resulted in the same error. I made sure I ran a snapshot task before running the replication task. Please advise what am I doing wrong?


Code:
[2024/02/07 19:55:51] INFO     [Thread-32] [zettarepl.paramiko.replication_task__task_1] Connected (version 2.0, client OpenSSH_8.8-hpn14v15)
[2024/02/07 19:55:51] INFO     [Thread-32] [zettarepl.paramiko.replication_task__task_1] Authentication (publickey) successful!
[2024/02/07 19:55:52] INFO     [replication_task__task_1] [zettarepl.replication.pre_retention] Pre-retention destroying snapshots: []
[2024/02/07 19:55:52] INFO     [replication_task__task_1] [zettarepl.replication.run] For replication task 'task_1': doing push from 'BIGASSRAID/test' to 'BIGASSZFS' of snapshot='auto-2024-02-07_19-55' incremental_base=None receive_resume_token=None encryption=False
[2024/02/07 19:55:52] INFO     [replication_task__task_1] [zettarepl.paramiko.replication_task__task_1.sftp] [chan 5] Opened sftp connection (server version 3)
[2024/02/07 19:55:52] INFO     [replication_task__task_1] [zettarepl.transport.ssh_netcat] Automatically chose connect address '192.168.1.6'
[2024/02/07 19:55:52] ERROR    [replication_task__task_1] [zettarepl.replication.run] For task 'task_1' unhandled replication error SshNetcatExecException(ExecException(1, 'pool or dataset is busy\n'), ExecException(1, 'I/O error\n'))
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 181, in run_replication_tasks
    retry_stuck_replication(
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/stuck.py", line 18, in retry_stuck_replication
    return func()
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 182, in <lambda>
    lambda: run_replication_task_part(replication_task, source_dataset, src_context, dst_context,
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 279, in run_replication_task_part
    run_replication_steps(step_templates, observer)
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 637, in run_replication_steps
    replicate_snapshots(step_template, incremental_base, snapshots, encryption, observer)
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 720, in replicate_snapshots
    run_replication_step(step, observer)
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/run.py", line 797, in run_replication_step
    ReplicationProcessRunner(process, monitor).run()
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/process_runner.py", line 33, in run
    raise self.process_exception
  File "/usr/local/lib/python3.9/site-packages/zettarepl/replication/process_runner.py", line 37, in _wait_process
    self.replication_process.wait()
  File "/usr/local/lib/python3.9/site-packages/zettarepl/transport/ssh_netcat.py", line 203, in wait
    raise SshNetcatExecException(connect_exec_error, self.listen_exec_error) from None
zettarepl.transport.ssh_netcat.SshNetcatExecException: Passive side: pool or dataset is busy
Active side: I/O error
 

bent98

Contributor
Joined
Jul 21, 2017
Messages
171
Screenshot 2024-02-10 104706.png
 

Apollo

Wizard
Joined
Jun 13, 2013
Messages
1,409
I tried to use TrueNAS replication over GUI without much success due to my snapshot naming scheme zettarepl.py doesn't support.
However, when I did experiment with it, I only used the "Transport" section to be "SSH" only ( not "SSH+NETCAT").
I suspect this is your issue.
 
Top