dual USB enclosure shows up oddly

Not open for further replies.


Apr 23, 2015
I have a usb enclosure for two disks that I would like to stripe and use as a backup volume.

When plugged in it creates two separate devices (da0 and da1) but the FreeNAS "View Disks" UI only shows one of them. Additionally, I've found one of them is "multipath" - I've tried removing that (gmultipath destroy disk1) but after a reboot that always come back.

I've found I can create a volume with or without destroying multipath first. The only difference is that when creating the volume the disk names show up as disk1/da1(without destroying) or da0/da1 (with destroying). This seems to "work", even after a reboot the volume exists, but still feels strange as I don't see two disks in "View Disks" - and as such I'm not very trusting.

Another tidbit I've uncovered:
If I do *not* remove multipath then I cannot write zeros to da0 (dd if=/dev/zero of=/dev/da0 bs=512) - I get "Operation not permitted". This is after a clean reboot and there's no volume in use yet. However, if I then 1) remove multipath 2) build a volume 3) export that volume -- only then will writing zeros work. However(!) I believe it crashed the whole system last night. Yep. I left 'dd' running overnight and woke up this morning to a "Unauthorized system reboot" email.

So yea, overall:
1) I can't seem to get the system to stop recognizing this disk as multipath (though, not really sure if that's a blocker)
2) Why would (dd if=/dev/zero of=/dev/da0 bs=512) crash the whole system? I'm running again today to verify...
3) Is it possible to reconfigure things to save logs before a crash?
4) any other thoughts?

Last edited by a moderator:


Documentation Engineer
Nov 14, 2014
The enclosure probably has a port multiplier. There are various opinions on these, ranging from "meh" to "avoid at all costs".

There is no point at all to setting bs=512 on dd. It is the default. Worse, the default is terribly slow for modern disks. Use a size of at least 64k. 1M is not too much. And it can be specified that way: bs=1m.
Not open for further replies.