Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Deluge plugin not installing

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

par

Member
Joined
Sep 26, 2013
Messages
85
The plugin install gets 95% of the way running post-install script then suddenly fails saying:
[EFAULT] Exception: CallError:[EFAULT] An error occured! Please read above occured, destroyed deluge.
I am able to install Plex without error. Tried deleting my whole iocage dataset but still get the same error.
I am on freenas 11.2-u3.
 

zvadasz

Newbie
Joined
Apr 13, 2019
Messages
2
I have the same problem. Fresh FreeNAS 11.2-u3 install, deluge plugin installation attempted with default setups (DHCP). Ended up with the exact same error message.
How can I get more information out of FreeNAS about the errors during plugin install?
 
D

dlavigne

Guest
That error typically means a network disruption. What is the full output of ifconfig (within code tags)? Are there any messages in /var/log/messages when the install failure occurs?
 

zvadasz

Newbie
Joined
Apr 13, 2019
Messages
2
Hi,
it happens while it is seemingly running post install, around 90%.
Any other plugin I tried installed as expected.

/var/log/messages:

Code:
Apr 16 22:29:24 constituo epair4a: Ethernet address: 02:66:d0:00:08:0a
Apr 16 22:29:24 constituo epair4b: Ethernet address: 02:66:d0:00:09:0b
Apr 16 22:29:24 constituo kernel: epair4a: link state changed to UP
Apr 16 22:29:24 constituo kernel: epair4a: link state changed to UP
Apr 16 22:29:24 constituo kernel: epair4b: link state changed to UP
Apr 16 22:29:24 constituo kernel: epair4b: link state changed to UP
Apr 16 22:29:24 constituo kernel: epair4a: changing name to 'vnet0:5'
Apr 16 22:29:24 constituo kernel: epair4b: changing name to 'epair0b'
Apr 16 22:29:24 constituo kernel: vnet0:5: promiscuous mode enabled
Apr 16 22:30:24 constituo kernel: vnet0:5: link state changed to DOWN
Apr 16 22:30:24 constituo kernel: vnet0:5: link state changed to DOWN
Apr 16 22:30:24 constituo kernel: epair0b: link state changed to DOWN
Apr 16 22:30:24 constituo kernel: epair0b: link state changed to DOWN
Apr 16 22:30:26 constituo epair4a: Ethernet address: 02:66:d0:00:08:0a
Apr 16 22:30:26 constituo epair4b: Ethernet address: 02:66:d0:00:09:0b
Apr 16 22:30:26 constituo kernel: epair4a: link state changed to UP
Apr 16 22:30:26 constituo kernel: epair4a: link state changed to UP
Apr 16 22:30:26 constituo kernel: epair4b: link state changed to UP
Apr 16 22:30:26 constituo kernel: epair4b: link state changed to UP
Apr 16 22:30:26 constituo kernel: epair4a: changing name to 'vnet0:6'
Apr 16 22:30:26 constituo kernel: epair4b: changing name to 'epair0b'
Apr 16 22:30:26 constituo kernel: vnet0:6: promiscuous mode enabled
Apr 16 22:30:33 constituo kernel: vnet0:6: link state changed to DOWN
Apr 16 22:30:33 constituo kernel: vnet0:6: link state changed to DOWN
Apr 16 22:30:33 constituo kernel: epair0b: link state changed to DOWN
Apr 16 22:30:33 constituo kernel: epair0b: link state changed to DOWN
Apr 16 22:30:33 constituo kernel: in6_purgeaddr: err=65, destination address delete failed


ifconfig:
Code:
root@constituo[~]# ifconfig
re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
    ether 50:46:5d:9e:88:43
    hwaddr 50:46:5d:9e:88:43
    inet 192.168.1.8 netmask 0xffffff00 broadcast 192.168.1.255
    nd6 options=9<PERFORMNUD,IFDISABLED>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 02:5b:a9:16:de:00
    nd6 options=1<PERFORMNUD>
    groups: bridge
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
    root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    member: vnet0:4 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 7 priority 128 path cost 2000
    member: vnet0:3 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 6 priority 128 path cost 2000
    member: vnet0:2 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 5 priority 128 path cost 2000
    member: vnet0:1 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 4 priority 128 path cost 2000
    member: re0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 1 priority 128 path cost 20000
vnet0:1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    description: associated with jail: plex as nic: epair0b
    options=8<VLAN_MTU>
    ether 50:46:5d:14:fa:09
    hwaddr 02:66:d0:00:04:0a
    nd6 options=1<PERFORMNUD>
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    groups: epair
vnet0:2: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    description: associated with jail: transmission as nic: epair0b
    options=8<VLAN_MTU>
    ether 50:46:5d:03:aa:46
    hwaddr 02:66:d0:00:05:0a
    nd6 options=1<PERFORMNUD>
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    groups: epair
vnet0:3: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    description: associated with jail: mineos as nic: epair0b
    options=8<VLAN_MTU>
    ether 50:46:5d:c5:1d:5f
    hwaddr 02:66:d0:00:06:0a
    nd6 options=1<PERFORMNUD>
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    groups: epair
vnet0:4: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
    description: associated with jail: madsonic as nic: epair0b
    options=8<VLAN_MTU>
    ether 50:46:5d:df:35:cc
    hwaddr 02:66:d0:00:07:0a
    nd6 options=1<PERFORMNUD>
    media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
    status: active
    groups: epair


Thanks, Z
 
D

dlavigne

Guest
Replace the Realtek NIC with one of the recommended (and affordable) Intel NICs in the Hardware Recommendations.
 

jcpolo

Neophyte
Joined
May 17, 2018
Messages
5
I have the same issue and I've tried running both the approved intel Nic's and the 10G Chelsio Nic's.
 

silverback

Member
Joined
Jun 26, 2016
Messages
116
Same Issue. Does the plugin work for anyone? Do we need to file a bug report?
 

jcpolo

Neophyte
Joined
May 17, 2018
Messages
5
That would probably be smart. I’ve read on many different threads this is the only plugin not working and people are having to manually install old versions to get it to work.
 
Top