Cifs -Freigaben machen seid der U6 probleme // smartd_daemon

Status
Not open for further replies.

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Moin, bin gestern auf die U6 umgestiegen, seidem funktioniert der Zugriff von meinem Raspberry pi (jdownloader) auf mein FreeNas nicht mehr.
Der Raspberry nutz die Freigabe auf dem NAS um die Dateien zu speichern.

Nach dem ich zurück auf die U5 bin klappt alles wieder problemlos.

Gibts aktuell eine Workaround für die U6.

Außerdem wurde leider das "smartd_daemon" problem nicht gefixt.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Moin, bin gestern auf die U6 umgestiegen, seidem funktioniert der Zugriff von meinem Raspberry pi (jdownloader) auf mein FreeNas nicht mehr.
Der Raspberry nutz die Freigabe auf dem NAS um die Dateien zu speichern.

Nach dem ich zurück auf die U5 bin klappt alles wieder problemlos.

Wird beim Zugriff vom Raspi aus irgendwelchen Gründen das veraltete SMB1 verwendet? Bei 11.1-U6 ist wird per Default in /usr/local/etc/smb4.conf die Einstellung server min protocol = SMB2 verwendet.

Schau z.B. hier (es gibt mehrere Threads dazu in den englischsprachigen Foren):
https://forums.freenas.org/index.ph...share-after-u6-update-smb-error-solved.69408/

Außerdem wurde leider das "smartd_daemon" problem nicht gefixt.

Die 11.1er Versionen versuchen, SMART-Tests auf den Bootmedien durchzuführen. Das ist Absicht und wird auch nicht gefixt. Startet der daemon bei Dir deswegen nicht? Falls Installation auf USB-Sticks, streiche das/die Boot-Medien aus der Liste der zu prüfenden Laufwerke.
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Die 11.1er Versionen versuchen, SMART-Tests auf den Bootmedien durchzuführen. Das ist Absicht und wird auch nicht gefixt. Startet der daemon bei Dir deswegen nicht? Falls Installation auf USB-Sticks, streiche das/die Boot-Medien aus der Liste der zu prüfenden Laufwerke.

Meinst du die SMART-tests unter Aufgaben, denn da steht nichts drin.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Meinst du die SMART-tests unter Aufgaben, denn da steht nichts drin.

Unter Tasks -> SMART Tests befindet sich für jeden eingerichteten Test zualleroberst eine Liste von Devices, für die die jeweiligen Tests durchgeführt werden sollen.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Moin, bin gestern auf die U6 umgestiegen, seidem funktioniert der Zugriff von meinem Raspberry pi (jdownloader) auf mein FreeNas nicht mehr.
Der Raspberry nutz die Freigabe auf dem NAS um die Dateien zu speichern.

Zwecks SMB Version: Unter raspbian_lite-2018-04-19 verwende ich übrigens die Option vers=3.0 im fs_mntops Feld in fstab für zu mountende SMB Shares und sonst keine weiteren diesbezüglichen Einstellungen.
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Unter Tasks -> SMART Tests befindet sich für jeden eingerichteten Test zualleroberst eine Liste von Devices, für die die jeweiligen Tests durchgeführt werden sollen.

Genau in dieser Liste sind bei mir keine Einträge vorhanden.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Genau in dieser Liste sind bei mir keine Einträge vorhanden.

Sind die Hardware-Angaben in Deiner Signatur noch aktuell? Um welche Syba Einsteckkarte handelt es sich genau?
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Ja die Hardware Angaben sind bis auf den Arbeitsspeicher aktuell. Diese liegen bei 32 GByte.

Folgende Karte ist verbaut
Syba SD-PEX40099 4 Port SATA III PCI-EXPRESS 2.0 x

Signatur passe ich sofort an.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Folgende Karte ist verbaut
Syba SD-PEX40099 4 Port SATA III PCI-EXPRESS 2.0 x

Ist zusätzlich auch noch ein SATA Port Multiplier im Spiel (z.B. in einem Plattengehäuse)?

Poste auch die Ausgaben von dmesg und pciconf -lvcb (jeweils in Code-Tags bitte), vielleicht kommen wir dem Grund so auf die Spur, weshalb die Liste der Devices für die SMART Tests nicht befüllt wird.

Ein möglicher Workaround wäre, Cron-Jobs anzulegen, die per Script SMART-Tests starten.

In diesem Thread hat übrigens jemand ein ähnlich gelagertes Problem, allerdings mit anderer Hardware:
https://forums.freenas.org/index.ph...o-freenas-11-1-u1-from-9-10-2-u6.61570/page-2
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Ein Sata-Multiplier ist nicht im Einsatz

Ich hänge es als txt an - da ich die Maximalen Zeichen überschreite.
 

Attachments

  • Log.txt
    47.6 KB · Views: 345

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Wunderbar - ich habe den oben gennanten Link benutzt und in den USB Laufwerken die SMART funktion deaktiviert. - Frage ist nur ob die USB Devices überhaupt SMART unterstützen.
 

mikalex

Dabbler
Joined
Aug 27, 2017
Messages
16
Moin, habe hier auch das Problem. Nach dem Update auf 11.1-U6 funktioniert der Zugriif auf Externe Speicher in meinem Nextcloud jail nicht mehr.
Nextcloud läuft bei mir in einem iocage jail. Wenn das was mit samba zu tun hat, wie kann ich dann den Zugriff auf die NAS-Freigaben uas den nextcloud-jail heraus testen?

Grüße
mikalex
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Moin, habe hier auch das Problem. Nach dem Update auf 11.1-U6 funktioniert der Zugriif auf Externe Speicher in meinem Nextcloud jail nicht mehr.
Nextcloud läuft bei mir in einem iocage jail. Wenn das was mit samba zu tun hat, wie kann ich dann den Zugriff auf die NAS-Freigaben uas den nextcloud-jail heraus testen?

Grüße
mikalex

Schau mal in die Speicher Freigaben deiner Nextcloud im freenas. Bei mir war auch eine Freigabe verschwunden.
 

mikalex

Dabbler
Joined
Aug 27, 2017
Messages
16
Die sind alle noch da. In den anderen jail's funktionieren die auch noch. Allerdings sind dies warden-jail's .
 

roki100

Dabbler
Joined
Nov 4, 2017
Messages
31
Moin, habe hier auch das Problem. Nach dem Update auf 11.1-U6 funktioniert der Zugriif auf Externe Speicher in meinem Nextcloud jail nicht mehr.
Nextcloud läuft bei mir in einem iocage jail. Wenn das was mit samba zu tun hat, wie kann ich dann den Zugriff auf die NAS-Freigaben uas den nextcloud-jail heraus testen?

Verstehe ich dich richtig, Du benutzt Samba um in (iocage) NextCloud auf deine NAS-Freigaben zuzugreifen? Wieso benutzt Du nicht iocage fstab? Falls Du doch iocage fstab bei der Installation von iocage+nextcloud verwendet hast, dann schau was "iocage fstab --list deinjailname" anzeigt.
 

555NASE

Patron
Joined
Mar 3, 2017
Messages
202
Wird beim Zugriff vom Raspi aus irgendwelchen Gründen das veraltete SMB1 verwendet? Bei 11.1-U6 ist wird per Default in /usr/local/etc/smb4.conf die Einstellung server min protocol = SMB2 verwendet.


Mein Dell MFC macht auch probleme beim Scannen - höchstwarscheinlich auch SMB1 - kann ich das NAS nicht so einstellen das es beide Protokolle benutzt oder wenigstens abwärtskompatible ist ?
 

mikalex

Dabbler
Joined
Aug 27, 2017
Messages
16
Habe mal mit
Code:
 iocage fstab -a nextcloud "/mnt/volume_1/media/bilder  /mnt/media/bilder  nullfs  rw  0  0"
einen share angelegt.

Code:
iocage fstab --list nextcloud
listet mir dann u.a. folgendes auf:
Code:
+-------+--------------------------------------------------------------------------------------------+
| 2	 | /mnt/volume_1/media/bilder /mnt/iocage/jails/nextcloud/root/mnt/media/bilder nullfs rw 0 0 |
+-------+--------------------------------------------------------------------------------------------+
In Nextcloud kann ich dann auch auf diesen share zugreifen, aber nur einen Ordner tief, die darunterliegenden Ordner sind leer.
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338

mikalex

Dabbler
Joined
Aug 27, 2017
Messages
16
@MrToddsFriends, Heureka, genau das wars :). Jetzt funktioniert es wieder wie vorher.

Vielen Dank
 

MrToddsFriends

Documentation Browser
Joined
Jan 12, 2015
Messages
1,338
Wunderbar - ich habe den oben gennanten Link benutzt und in den USB Laufwerken die SMART funktion deaktiviert. - Frage ist nur ob die USB Devices überhaupt SMART unterstützen.

USB-Sticks meines Wissen generell nicht. Per USB angebundene (z.B. externe) HDDs oder SSDs unterstützen das eventuell, ja nach Fähigkeiten des SATA-USB-Adapters.

Mittlerweile sieht es doch so aus, als würde das Problem "smartd startet bei Vorhandensein von USB Bootdevices nicht" in einem kommenden 11.1-U7 gefixt werden.
https://redmine.ixsystems.com/issues/43042
 
Status
Not open for further replies.
Top