Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

can't create zfs volume

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

stsostso

Neophyte
Joined
Jan 27, 2013
Messages
10
Hi,

I have three disks in my Freenas. I had them divided into two volumes. Now I wanted to convert them into one volume. So I detached both volumes and started the Volume Manager to create a new volume with all three disks. I selected the three discs, selected ZFS, checked “enable full disk description!” and “Initialize with random data”, selected RAID-Z and added the volume. I took a while and after it was done, the volume did not show in the list.

I tried the same procedure again but I got some message saying that it can not access the database (I forgot the exact message).

I rebooted the system, wiped the disks manually and tried it again. Still no volume. Now I get the following message when I look at the shell:

freenas manage.py: [middleware.exceptions:38][MiddlewareError: Unable to GPT format the disk “ada0”]

How can I fix this?

PS: I saved the data before I made any changes
 
Status
Not open for further replies.
Top