Cannot install Truecommand docker either in SCALE or in a VM.


Apr 28, 2021
I am trying to install Truecommand and have been unsuccessful so far. It's an optional project since I only have two Truenas servers to manage at the moment. However, I think it would be fun and at least somewhat useful. I have no prior experience with docker containers. Perhaps someone can give me some pointers.

So far I have tried installing it two different ways, and neither way works. First, I tried installing it as a custom app in Truenas SCALE, but the process gave an error message and failed.

Second, I tried installing it in a VM running in SCALE, specifically Ubuntu server, which is Ubuntu without a desktop/GUI. I followed the directions here: I installed the docker engine SNAP, which was easy. But then I ran into a problem in that the directions call for the installation of "docker desktop," which is apparently a VM that cannot run nested in another VM, so I don't see how it's possible to install Truecommand in a VM, and I'm not willing to dedicate a bare metal computer for this. Without docker desktop, the rest of the installation process failed with a port error.

Does anyone know the easiest way to install Truecommand? For example, maybe there is a way to avoid installing docker desktop when installing Truecommand in a VM.
Last edited: