Can view shares across subnets, but unable to authenticate

Status
Not open for further replies.

poopsie

Cadet
Joined
Apr 14, 2018
Messages
3
Build FreeNAS-11.1-U4
Platform Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz
Memory 8142M
Motherboard intel?
NIC - Onboard intel board
Hard Drives - 5 x 4TB WD RED - RAID Z1

Here is my dilemma. I have an UNRAID server and Freenas server on my network. Both are on the 10.21.32.* subnet. Anything on that subnet, and anything that comes in on VPN are able to authenticate no problem.

I have another subnet on 10.10.50.* Any of the computers on that subnet are able to browse and authenticate no problem on UNRAID. But, when I go to Freenas from those machines, I can browse the shares, but not able to login. I get the Wrong username or password error. I have tried logging in with .\username but still no luck. If I enable guest, they can access the shares fine on Freenas.

All of the machines are Windows 7

No Domain, only WORKGROUP

I am able to ping Freenas from the 10.10.50.0 subnet with no issues

Any guidance from the Freenas gods would be appreciated!!

Thanks
 
Last edited:

Mihalich

Patron
Joined
Mar 14, 2017
Messages
297
10.10.50.0 subnet - this is another broadcast domain.
try to access the shared folder by \\FreenasIP\shared_folder\
 

poopsie

Cadet
Joined
Apr 14, 2018
Messages
3
10.10.50.0 subnet - this is another broadcast domain.
try to access the shared folder by \\FreenasIP\shared_folder\

Thanks for the reply. I only use IP's, as the hostnames do not forward across subnets. The pictures show what the issue is. No matter how I try to login I get access denied. I can see the share no problem, and I can access the unraid server no problem. I am just stuck on Freenas.
 

Attachments

  • 1.PNG
    1.PNG
    22.6 KB · Views: 317
  • 2.PNG
    2.PNG
    55.5 KB · Views: 302
  • 3.PNG
    3.PNG
    56.1 KB · Views: 321
  • 4.PNG
    4.PNG
    57.1 KB · Views: 313

Mihalich

Patron
Joined
Mar 14, 2017
Messages
297
Ok. Show your SMB settings and permissions on the dataset.
 

poopsie

Cadet
Joined
Apr 14, 2018
Messages
3
After some research on from another post, this did it!

"Adding ntlm auth = yes to "Auxiliary parameters" on the SMB Share seems to do the trick."

Thanks for your help!!
 
Status
Not open for further replies.
Top