can not increase size of zvol after expanding pool


Jan 9, 2020
First all, I am extremely new to FreeNAS and I am learning this system in a live environment as I go along. I have read up on some of the basics, but I am running into an issue that I can't quite understand.

Here is a bit of information about our environment:
Physical Memory:
8124 MiB
Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz

Currently, our SAN has 37 disks attached. 35 of these are meant for creating our storage pool. We are bundling these disks together 5 at a time and configuring them into a RaidZ1 setup. We should end up with 7 vdevs to make up our ZFS pool. We would like to start off with only 2 vdevs to start. The Pool is then going to to be used to store a zvol which will be attached to our server via iSCSI.

I wanted to take the setup one step at a time to make sure I understood how we would extend our pool/zvol in the future. To replicate this, I created a new pool with just one of the vdevs (5 - 6TB disks with RaidZ1). Everything looked good to start. Our pool was created and saw that we had a dataset with 21.09 TiB available. I then proceeded in creating the zvol, keeping in mind to only utilize 80% of the total size. (21.09 * 0.8 = 16.87 TiB).

I created the zvol and set the size to be 16.87 with no issues. Our dataset showed 16.94 TiB Used and 4.15 TiB available (this seems like 80% of the pool that will be available to us for storage, and the 20% that is recommended to keep available). When looking at the vzol, I see that we had a volume with 16.94 TiB Used and 21.09 TiB available. Everything looked great, until the next step.

Next, I extended the pool, adding in another vdev (5 - 6TB disks with RaidZ1). This is when things got a bit confusing... Our dataset then showed the same 16.94 TiB Used, but now 25.24 TiB available. If I try and increase the size of the zvol, we recieve a warning: "It is not recommended to use more than 80% of your available space for VOLUME ".

According to my calculations, I should have been able to increase the zvol by another 16.87 TiB which would make the zvol total size at around 33.74 TiB. I couldn't even increase the zvol from 16.87 TiB to 17 TiB without receiving the warning about not exceeding 80% (same error listed above).

I am guessing there is something that needs done with the dataset since it shows 25.24 TiB available after the pool was extended? I cant quite figure out the next step I need to perform in order to get the second vdev incorporated into our pool so it can be used to increase the size of our zvol.

I have tried to troubleshoot this issue by deleting the pool and recreating it. This time, I added the first vdev (5 - 6TB disks with RaidZ1). I then extended the pool by creating the second vdev (5 - 6TB disks with RaidZ1). After this, I saw that I had the desired 42.18 TiB available in our dataset, which if I tool 80% of that and turned it into a zvol (42.18 * 0.8 = 33.74 TiB). I can successfully create our desired 33.74 TiB zvol if I extend the pool before creating the zvol. This is a workaround for the time being, but in the future when we add additional storage to this pool, I would like to know how to get around this issue.

Any help would be greatly appreciated!


Oct 29, 2016
my first guess would be that it is checking the new zvol size against the pools available space, as if it was a brand new zvol, finding that 16+TiB is much larger than 5TiB, and giving you an error.