Another updating plex thred....


Jan 17, 2014
I have been banging my head against the wall trying to upgrade my iocage plex install in freenas 11.3.

I believe it was originally installed as a plugin but not 100% sure, it was so long ago.
plex is installed to /Plex Media Server/ it is the plexpass version.

I have confirmed pkg info shows "plexmediaserver-plexpass- Plex Media Server component"

I have tried updating the plugin through the gui, after the update I get a 404 error. > rollback snapshot

I have tried upgrading through pkg, after running the upgrade same error and issuing "service plexmediaserver_plexpass restart" says "plexmediaserver-plexpass does not exist in /etc/rc.d or the local startup" > rollback snapshot

I have tried renaming files found in another post and then running the upgrade > rollback snapshot

So I love being able to rollback snapshots but would really like to upgrade plex!

any help would be amazing!
Jan 4, 2014
I believe it was originally installed as a plugin but not 100% sure,
Check in the GUI under Plugins. If you did install it as a plugin, it will be obvious there.

There are several issues with continuing to use the plugin. For example, Plex metadata is stored inside rather than outside the jail. This needs to be considered if you decide to start over and rebuild the jail from scratch anytime in the future. Another issue is that updating Plex is a manual process. Given the frequency of Plex updates, this can quickly become tiresome.

Make life easy for yourself. Save your Plex metadata for later restoration (see this post for tips and then use @danb35's scripted Plex resource for a pain-free approach to using Plex on FreeNAS.

Also, when you're revisiting this thread, consider adding your FreeNAS h/w and s/w details to your signature block. This will encourage forum members to assist you with future postings.
Last edited:


Jan 15, 2020
I'm updating the plug-in with this method
jexec 3 csh  #Enter ID plex jls
fetch -o
chmod 755
./ -vv -a