• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

8.01beta3 smartd will not start

Status
Not open for further replies.

jstrebel

Dabbler
Joined
Jun 6, 2011
Messages
20
Hi,
I tried to start S.M.A.R.T in the services menue. This produces the following entry in the log and SMART remains on off. Looking in the bug reporting I found entry but its not clear to me if the reporter of that bug experience the same problem.

Best regards Jakob


Jul 2 18:31:28 freenas freenas[1615]: Executing: /usr/sbin/service ix-smartd quietstart
592:Jul 2 18:31:28 freenas freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
597:Jul 2 18:31:31 freenas freenas[1615]: Executing: /usr/sbin/service smartd restart
598:Jul 2 18:31:31 freenas freenas: Stopping smartd.
599:Jul 2 18:31:31 freenas freenas: Will not 'start' smartd because smartd_enable is NO.
605:Jul 2 18:33:04 freenas freenas[1615]: Executing: /usr/sbin/service ix-smartd quietstart
606:Jul 2 18:33:04 freenas freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
611:Jul 2 18:33:07 freenas freenas[1615]: Executing: /usr/sbin/service smartd restart
612:Jul 2 18:33:07 freenas freenas: Will not 'restart' smartd because smartd_enable is NO.
615:Jul 2 18:33:18 freenas freenas[1615]: Executing: /usr/sbin/service ix-smartd quietstart
616:Jul 2 18:33:19 freenas freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
621:Jul 2 18:33:21 freenas freenas[1615]: Executing: /usr/sbin/service smartd restart
622:Jul 2 18:33:21 freenas freenas: Will not 'restart' smartd because smartd_enable is NO.
625:Jul 2 18:33:52 freenas freenas[1615]: Executing: /usr/sbin/service ix-smartd quietstart
626:Jul 2 18:33:52 freenas freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
631:Jul 2 18:33:55 freenas freenas[1615]: Executing: /usr/sbin/service smartd restart
632:Jul 2 18:33:55 freenas freenas: Will not 'restart' smartd because smartd_enable is NO.
635:Jul 2 18:33:58 freenas freenas[1615]: Executing: /usr/sbin/service ix-smartd quietstart
636:Jul 2 18:33:58 freenas freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
641:Jul 2 18:34:02 freenas freenas[1615]: Executing: /usr/sbin/service smartd restart
642:Jul 2 18:34:02 freenas freenas: smartd not running? (check /var/run/smartd.pid).
643:Jul 2 18:34:02 freenas freenas: Starting smartd.
 

Tekkie

Patron
Joined
May 31, 2011
Messages
352
Bugger! That's exactly one of the feature of B3 that I was looking forward to... :(
 

adad

Cadet
Joined
May 31, 2011
Messages
2
Same here. I can't start S.M.A.R.T. over the services menu.

"The service cannot be started" is displayed.
 

jstrebel

Dabbler
Joined
Jun 6, 2011
Messages
20
Hi, I am using i386 version. Is my assumption right, that I can not update it with the AMD version using a Intel CPU?
jakob
 
B

Bohs Hansen

Guest
amd64 = 64bit. The amd comes because amd was first with this processor architecture.
 

matt8534

Cadet
Joined
Jul 19, 2011
Messages
7
I have FreeNAS-8.0.1-BETA4-amd64 installed and smartd won't start for me either.

Code:
Jul 19 15:08:14 lockbox freenas[1563]: Executing: /usr/sbin/service ix-smartd quietstart
Jul 19 16:08:14 lockbox freenas: generate_smartd_cfg > /usr/local/etc/smartd.conf
Jul 19 16:08:15 lockbox freenas[21933]: Popen()ing: sysctl -b kern.geom.confxml
Jul 19 15:08:15 lockbox freenas[1563]: Executing: /usr/sbin/service smartd restart
Jul 19 16:08:15 lockbox freenas: smartd not running? (check /var/run/smartd.pid).
Jul 19 16:08:15 lockbox freenas: Starting smartd.
Jul 19 16:08:15 lockbox root: /usr/local/etc/rc.d/smartd: WARNING: failed to start smartd
Jul 19 16:08:15 lockbox freenas: /usr/local/etc/rc.d/smartd: WARNING: failed to start smartd
Jul 19 15:08:15 lockbox freenas[1563]: Executing: /bin/pgrep -F /var/run/smartd.pid smartd

 

Tekkie

Patron
Joined
May 31, 2011
Messages
352
@matt

make a change that affects the smartd configuration and try starting the service then, at least that did the trick for me.
 

matt8534

Cadet
Joined
Jul 19, 2011
Messages
7
Setup a scheduled scan as well as changed SMART settings... Service still won't start. Maybe because I'm using a 3Ware RAID controller?
 

matt8534

Cadet
Joined
Jul 19, 2011
Messages
7
Upgraded to FreeNAS-8.0.1-RC1-amd64 (7508) - still can't start smartd......

Code:
Sep  1 09:19:13 lockbox freenas[1660]: Popen()ing: sysctl -b kern.geom.confxml
Sep  1 09:19:13 lockbox freenas[1660]: Popen()ing: sysctl -b kern.geom.confxml
Sep  1 09:19:14 lockbox freenas[1660]: Executing: /usr/sbin/service ix-smartd quietstart
Sep  1 09:19:14 lockbox freenas[3317]: Popen()ing: sysctl -b kern.geom.confxml
Sep  1 09:19:15 lockbox freenas[3335]: Popen()ing: sysctl -b kern.geom.confxml
Sep  1 09:19:15 lockbox freenas[1660]: Executing: /usr/sbin/service smartd restart
Sep  1 09:19:15 lockbox freenas: smartd not running? (check /var/run/smartd.pid).
Sep  1 09:19:15 lockbox freenas: Starting smartd.
Sep  1 09:19:15 lockbox root: /usr/local/etc/rc.d/smartd: WARNING: failed to start smartd
Sep  1 09:19:15 lockbox freenas: /usr/local/etc/rc.d/smartd: WARNING: failed to start smartd
Sep  1 09:19:15 lockbox freenas[1660]: Executing: /bin/pgrep -F /var/run/smartd.pid smartd
 
Status
Not open for further replies.
Top