Unable to start Sabnzbd

Status
Not open for further replies.

Seth Tipton

Cadet
Joined
Aug 27, 2013
Messages
6
I'm kind of new at this and haven't had to touch my system in years because it's been running well so I apologize.

My Sabnzbdplus 0.7.14 is stuck in the off position and I can't view it in the browser.

When I try to edit my storage under Jails>Storage for SABnzbd I get this traceback in the popup

Environment:

Software Version: FreeNAS-9.1.0-RELEASE-x64 (dff7d13)
Request Method: GET
Request URL: http://192.168.1.98/admin/jails/nullmountpoint/edit/5/


Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
109. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
165. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
25. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in wrapper
158. return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/utils/decorators.py" in _wrapped_view
91. response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python2.7/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
89. response = view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py" in inner
140. return view(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in edit
486. mf = mf(instance=instance)
File "/usr/local/www/freenasUI/../freenasUI/jails/forms.py" in __init__
724. jail_path = "%s/%s" % (self.jc.jc_path, self.jail.jail_host)

Exception Type: AttributeError at /admin/jails/nullmountpoint/edit/5/
Exception Value: 'NoneType' object has no attribute 'jail_host'


​
I also have this freenas warning

WARNING: The volume RAID (ZFS) status is UNKNOWN: One or more devices has experienced an error resulting in data corruption. Applications may be affected.Restore the file in question if possible. Otherwise restore the entire pool from backup.

​
All of my other plugins are working as expected.
 
D

dlavigne

Guest
Post the output of zpool status using Insert -> Code.
 

Seth Tipton

Cadet
Joined
Aug 27, 2013
Messages
6
Code:
[root@freenas ~]# zpool status -v                                                                                                 
  pool: RAID                                                                                                                      
state: ONLINE                                                                                                                    
status: One or more devices has experienced an error resulting in data                                                            
        corruption.  Applications may be affected.                                                                                
action: Restore the file in question if possible.  Otherwise restore the                                                          
        entire pool from backup.                                                                                                  
   see: http://illumos.org/msg/ZFS-8000-8A                                                                                        
  scan: scrub repaired 336K in 2h26m with 4 errors on Sun Dec 13 02:27:01 2015                                                    
config:                                                                                                                           
                                                                                                                                  
        NAME                                          STATE     READ WRITE CKSUM                                                  
        RAID                                          ONLINE       0     0     0                                                  
          gptid/e3cd8183-52c9-11e3-b0a1-bc5ff4ac7c22  ONLINE       0     0     0                                                  
          gptid/e427ad71-52c9-11e3-b0a1-bc5ff4ac7c22  ONLINE       0     0     0                                                  
          gptid/e47837a0-52c9-11e3-b0a1-bc5ff4ac7c22  ONLINE       0     0     0                                                  
          gptid/e4c9b2aa-52c9-11e3-b0a1-bc5ff4ac7c22  ONLINE       0     0     0                                                  
                                                                                                                                  
errors: Permanent errors have been detected in the following files:                                                               
                                                                                                                                  
        /mnt/RAID/.sabnzbd_1.meta/fstab                                                                                           
        RAID/Media_Store:<0x13bf>                                                                                                 
        RAID/Media_Store:<0x3bea> 
 
Last edited:

danb35

Hall of Famer
Joined
Aug 16, 2011
Messages
15,504
You have four disks in a striped configuration, which means you have no redundancy in your pool. This means that any corruption on any drive will result in corruption and/or loss of data in your pool. In your case, there are errors in two metadata blocks in your Media_Store dataset, as well as the what appears to be the filesystem configuration file for your SABNZBd jail.
 
Status
Not open for further replies.
Top