Trying to delete snapshots, errors states "dependent clones"

Status
Not open for further replies.

asw2012

Contributor
Joined
Dec 17, 2012
Messages
182
Hi,
I've been trying to delete some snapshots on FreeNAS 9.3 - See the errors attached when I try to delete them. I've also been scouring and searching for this particular problem, but I can't seem to find a solution - or one that I fully understand.

Thank You.
 

Attachments

  • Error_1.png
    Error_1.png
    6.6 KB · Views: 402
  • Error_2.png
    Error_2.png
    5.7 KB · Views: 373
  • Error_3.png
    Error_3.png
    5.8 KB · Views: 358
Last edited by a moderator:

asw2012

Contributor
Joined
Dec 17, 2012
Messages
182
Thanks for the reply, and it looks like it does cover what I have to do... but
I try and copy the command in and no information is displayed. I'm doing something wrong.

Code:
[root@15TBNAS ~]# zdb -d RAIDz2 |grep "%"
[root@15TBNAS ~]#
 
Last edited by a moderator:

garm

Wizard
Joined
Aug 19, 2017
Messages
1,556
Why do you want to delete the jail template snapshots? Those are what your jails are based on.
 

asw2012

Contributor
Joined
Dec 17, 2012
Messages
182
Why do you want to delete the jail template snapshots? Those are what your jails are based on.
I've had a problem with snapshots eating up all of the NAS space, over 6TB worth, and it's happening again. These are the last three snapshots that need to be deleted so I can free up about 6TB of space.
 

asw2012

Contributor
Joined
Dec 17, 2012
Messages
182
I highly doubt those snapshots contain 6 TB
the last time I deleted all of the snapshots, 6TB appeared again. This is why I am suspicious of them.
I still have not been able to find a way to delete them.
 

garm

Wizard
Joined
Aug 19, 2017
Messages
1,556
As long as you have jails you cannot delete the jail templates, that is those snapshots
 
Status
Not open for further replies.
Top