Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SSH login denied GUI stuck at "connecting to freenas"

Michael Hanna

Member
Joined
Jun 17, 2017
Messages
43
Ok, so my problem is as the title suggests. One of my Freenas servers is stuck in a odd state. The web GUI is stuck at a message saying "Connecting to FreeNAS... Make sure the system is powered on and connected to the network". I've tried multiple browsers all the with same result. When trying to log in via ssh using a known good password I just get an "access denied" message. I've connected via virtual console to the server and manually reset the root password and immediately tried to SSH in with the newly reset password and still "access denied". Oddly enough replication tasks from my primary FreeNAS server to this server or completing without error. I've tried outright rebooting the server all symptoms are the same. Looking for any pointers to get me access to this server.
 

Chris Moore

Wizened Sage
Joined
May 2, 2015
Messages
9,719
Six network ports, how many IP addresses do you have configured? How many networks?
 

Michael Hanna

Member
Joined
Jun 17, 2017
Messages
43
I guess I should have clarified a little bit. My signature contains the spec for my primary FreeNAS server. On that server I actually only have one of 10G nics active and configured. On my backup FreeNAS (the one I'm having issues accessing) there are only 2 nic and only one of those is configured. The backup server console shows only one IP. Which I can ping and can connect via SSH but just am unable to actually log in even with a known good password.
 

Michael Hanna

Member
Joined
Jun 17, 2017
Messages
43
I was able to work out this issue. The first issue of the webgui not loading I was able to get around by using HTTPS instead of HTTP. Not sure why HTTPS works but not HTTP but that will be an issue for me to figure out another day. The SSH login issue was caused by me no checking the "login as root user with password" option when I activated the SSH service.
 
Top