SOLVED SMB refuses to start

Not open for further replies.


Mar 15, 2018
Hey all,

recently I made a pretty bad mistake of chowning my entire file structure to media:media.
Most of that saga can be found here:

I've been trying to fix my mistake for a couple of days now. Going to the extent of completely reinstalling FreeNAS, in the hopes that it would fix it.

However, for whatever reason my FreeNAS refuses to start the SMB service.

Checking in shell with smbstatus I get messaging_init failed

If I try to start it from the services menu I see the following exception:

Request Method: POST
Request URL:
Software Version: FreeNAS-11.1-U2 (c636d1f4b)
Exception Type: ServiceFailed
Exception Value:
The SMB service failed to reload.
Exception Location: ./freenasUI/services/ in save, line 268
Server time: Mon, 19 Mar 2018 00:17:06 -0700


Request information
No GET data

Variable Value
__all__ ''
cifs_srv_netbiosname 'freenas'
cifs_srv_netbiosalias ''
cifs_srv_workgroup 'WORKGROUP'
cifs_srv_description 'FreeNAS Server'
cifs_srv_doscharset 'CP437'
cifs_srv_unixcharset 'UTF-8'
cifs_srv_loglevel '1'
cifs_srv_localmaster 'on'
cifs_srv_timeserver 'on'
cifs_srv_guest 'nobody'
cifs_srv_filemask ''
cifs_srv_dirmask ''
cifs_srv_smb_options ''
cifs_srv_unixext 'on'
cifs_srv_zeroconf 'on'
cifs_srv_hostlookup 'on'
cifs_srv_allow_execute_always 'on'
cifs_srv_obey_pam_restrictions 'on'
idmap_tdb_range_low '90000001'
idmap_tdb_range_high '100000000'
__form_id 'dialogForm_'
No FILES data

Variable Value
csrftoken '********'
sessionid 'deupc5uk7rhqgoneum2l591ru8z1jxps'
fntreeSaveStateCookie 'root%2Croot%2F133%2F143%2Croot%2F80%2F81%2F82%2Croot%2F80%2F81%2Croot%2F80%2F81%2F82%2F87%2Croot%2F195%2F201%2F203%2Croot%2F195%2F206%2Croot%2F195%2F206%2F208%2Croot%2F195%2F201%2Croot%2F82%2F83%2F84%2Croot%2F82%2F83%2F84%2F89%2Croot%2F192%2Croot%2F49%2F62%2Croot%2F195%2Croot%2F203%2F219%2Croot%2F199%2Croot%2F203%2Croot%2F196%2Croot%2F212%2Croot%2F10%2Croot%2F211%2Croot%2F211%2F217%2Croot%2F211%2F217%2F219%2Croot%2F1%2F6%2Croot%2F82%2Croot%2F82%2F83%2Croot%2F82%2F83%2F84%2F89%2F106%2Croot%2F1%2F8%2Croot%2F203%2F209%2Croot%2F212%2F222%2Croot%2F217%2F227%2F229%2Croot%2F84%2F85%2Croot%2F84%2F85%2F86%2Croot%2F84%2F85%2F86%2F87%2Croot%2F132%2F142%2Croot%2F189%2Croot%2F189%2F195%2Croot%2F189%2F195%2F197%2Croot%2F191%2Croot%2F191%2F197%2Croot%2F122%2Croot%2F122%2F132%2Croot%2F197%2Croot%2F1%2Croot%2F1%2F2%2Croot%2F1%2F7%2Croot%2F81%2F82%2Croot%2F81%2F82%2F83%2Croot%2F81%2F82%2F83%2F84%2Croot%2F81%2F82%2F83%2F88%2Croot%2F150%2F160%2Croot%2F209%2F215%2Croot%2F11%2Croot%2F184'
Variable Value

I also ran testparam and got this:

testparm /usr/local/etc/smb4.conf																				
Load smb config files from /usr/local/etc/smb4.conf																				
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)														  
Processing section "[Gringotts]"																									
Loaded services file OK.																											
Server role: ROLE_STANDALONE																										
Press enter to see a dump of your service definitions																			  

# Global parameters																												
	   dos charset = CP437																										
	   server string = FreeNAS Server																							
	   lm announce = Yes																										  
	   nsupdate command = /usr/local/bin/samba-nsupdate -g																		
	   logging = file																											
	   max log size = 51200																										
	   kernel change notify = No																								  
	   panic action = /usr/local/libexec/samba/samba-backtrace																	
	   disable spoolss = Yes																									  
	   load printers = No																										
	   printcap name = /dev/null																								  
	   time server = Yes																										  
	   map to guest = Bad User																									
	   obey pam restrictions = Yes																								
	   security = USER																											
	   server role = standalone server																							
	   deadtime = 15																											  
	   hostname lookups = Yes																									
	   max open files = 940673																									
	   dns proxy = No																											
	   idmap config *: range = 90000001-100000000																				
	   idmap config * : backend = tdb																							
	   store dos attributes = Yes																								
	   strict locking = No																										
	   directory name cache size = 0																							  
	   dos filemode = Yes																										
	   acl allow execute always = Yes																							
	   ea support = Yes																											
	   create mask = 0666																										
	   directory mask = 0777																									  
	   path = "/mnt/Gringotts/Gringotts"																						  
	   hide dot files = No																										
	   veto files = /.snapshot/.windows/.mac/.zfs/																				
	   read only = No																											
	   vfs objects = zfs_space zfsacl streams_xattr																				
	   zfsacl:acesort = dontcare																								  
	   nfs4:chown = true																										  
	   nfs4:acedup = merge																										
	   nfs4:mode = special  

I'm not really sure what is going wrong here. I probably screwed something up required for SMB to function correctly when I chowned everything to media:media. But I figured reinstalling FreeNAS and changing the ownership of every file after reimporting the volume would fix the issue.

Here are some screenshots of my setup.

Ls -l of file structure:

storage permissions of the main mount:

storage permissions for the windows subfolder:

Windows share setting:

Smb services settings:


User added to shared and media groups:

I'm not really sure what's going wrong here.
The documentation located here:
Seems to mention a command called: winacl

Which seems to me to probably have something to do with what I want. Considering its brings it up during a sentence about chown, and what to do if you accidentally ran it (Like I did).

But I'm not entirely sure how to run that command.
I'm also not sure if I'm even barking up the right tree or not.

Do any of you have any idea what might be going wrong here?

Thanks a bunch for taking the time to look at my post.
Last edited by a moderator:


Mar 15, 2018
Did some more snooping around.

Checking with service -e I see:


In the list, but if I try service samba_service start it mentions it not existing in local start up:

[root@freenas ~]# service samba_service start																					   
samba_service does not exist in /etc/rc.d or the local startup																	 
directories (/etc/ix.rc.d /usr/local/etc/rc.d), or is not executable 

Not sure if this means anything or not.

Mostly just poking around in the dark here, the exception seems to mention root a bunch of times in fntreeSaveStateCookie but I have no idea how to resolve it.

Freenas seems to use samba version 4.7.0, maybe if I try to upgrade it to the latest version, it will do something?


Mar 15, 2018
So I have no idea how I fixed it. But I updated to FreeNAS 11-u3 and its working now. SMB started up no problems at all.

Not sure what happened here. But its up woo!.

Have a good one everyone!
Last edited by a moderator:
Not open for further replies.