Slow deleting large amount of files using SMB on 11.1-U2

Pointeo13

Explorer
Joined
Apr 18, 2014
Messages
86
Anyone experiencing this issue with 11.1-U2? When I try to deleting couple 100GB+ worth of files through SMB, its really slow and at various times it's stuck deleting for 10-20 seconds and then resumes again. At first I i tried to delete my normal 2TB's worth of files, but that really hosed up the system so I had to kill the delete job. I went ahead and reverted back to 11.0-U4 again and everything is working fine. During the delete I noticed if i'm trying to access the shares it's super slow, or took forever to respond going through the directories.
 

Nick2253

Wizard
Joined
Apr 21, 2014
Messages
1,633
Are you deleting the files via a Windows client? Are they big files, or lots of small files? Can you check CPU/memory usage while you're deleting the files?
 

Pointeo13

Explorer
Joined
Apr 18, 2014
Messages
86
Correct, I'm deleting via Windows client. The files will be anywhere from 500MB-10GB, and I was trying to delete a couple thousand of these files. CPU and memory usage was just fine, it was not acting like a post I made a few yeas ago.

https://forums.freenas.org/index.ph...results-in-ctl_datamove-tag-on-aborted.40119/

Edit: Just tried it again with 333 files (1GB-10GB range), and just very slow and jerky trying to delete files and super slow browsing the shares during that time.
 

Attachments

  • 1. Info.PNG
    1. Info.PNG
    8.2 KB · Views: 340
  • 2. CPU.PNG
    2. CPU.PNG
    39.1 KB · Views: 344
  • 3. Memory.PNG
    3. Memory.PNG
    34.6 KB · Views: 331
  • 4. Networking.PNG
    4. Networking.PNG
    68 KB · Views: 303
  • 5. Arc.PNG
    5. Arc.PNG
    115.1 KB · Views: 329
Last edited:

MagellanTX

Cadet
Joined
Jan 10, 2020
Messages
2
Did you ever find a fix for this? I have the exact same problem with 11.2-U7.

My NAS is all SSD, no compression, no dedup, and no RAID (it's hardware RAID). I can read/write ~120MB/sec but it calculates over 5 hours to delete 300G (all files are 2 - 10G each). What's weird is that if I delete the files individually, it's instant but If I select them in bulk, it's miserably slow.

I'm wondering if it's something related to the SMB service though? I noticed that when it's trying to delete these files, no one else on the network (including me) can access the shares.


Correct, I'm deleting via Windows client. The files will be anywhere from 500MB-10GB, and I was trying to delete a couple thousand of these files. CPU and memory usage was just fine, it was not acting like a post I made a few yeas ago.

https://forums.freenas.org/index.ph...results-in-ctl_datamove-tag-on-aborted.40119/

Edit: Just tried it again with 333 files (1GB-10GB range), and just very slow and jerky trying to delete files and super slow browsing the shares during that time.
 

Pointeo13

Explorer
Joined
Apr 18, 2014
Messages
86
Did you ever find a fix for this? I have the exact same problem with 11.2-U7.

My NAS is all SSD, no compression, no dedup, and no RAID (it's hardware RAID). I can read/write ~120MB/sec but it calculates over 5 hours to delete 300G (all files are 2 - 10G each). What's weird is that if I delete the files individually, it's instant but If I select them in bulk, it's miserably slow.

I'm wondering if it's something related to the SMB service though? I noticed that when it's trying to delete these files, no one else on the network (including me) can access the shares.

Its been an on and off issue depending on the FresNas version, currently I am having issues with delete on version 11.2-U7. I delete at least 1TB of data a week through SMB, so I'm having to do a couple hundred GB per chunk without causing too many issues. They have fixed the issue in the past, I'll never forget the day when they fixed the issue in FreeNAS-9.10 and was fine up through 11.0-U4 but now it's back again.

When i try to delete, SMB becomes unresponsive, and the netdata page is the same way, it stops, updates, stops, updates etc.
 
Last edited:

StrikeLines

Cadet
Joined
Dec 5, 2019
Messages
3
I'm seeing the same behavior. Small numbers of files delete instantly, but if you try to delete more than 100 or so at a time, only 2-3 files per minute are deleted. FreeNAS-11.2-U7
 

Pointeo13

Explorer
Joined
Apr 18, 2014
Messages
86
If someone from freenas wants me to enable some kind of advance logging and have me delete a big chunk of data, let me know, I can open up a ticket and upload the logs.
 

Pointeo13

Explorer
Joined
Apr 18, 2014
Messages
86
Just wanted to give an update, I updated to TrueNAS-12.0-RC1 which has resolved my issue, its a night and day difference.
 
Top