Problem installing Guest OS


Mar 16, 2024
I'm new to TrueNAS, but not Linux. I prefer to solve problems on my own but I'm at a point I need help figuring out what I'm doing wrong. The system is a home-built Ryzen 7600x, MSI motherboard, using an old 128GB SSD for the system and a pool of three 8TB HDD. Nothing unusual, no overclocking, no graphic card, the system was very stable under windows, virtualization is on and it was running WSL when on Windows. All software is latest versions.

When I follow (meticulously, time after time) the tutorials and You-Tube vids on adding a VM, I throw the switch, get a spinning wait icon for a couple seconds, then the switch turns blue and new buttons are added. Clicking on the Display button brings up two small windows, on bottom it says Open Dis (rest covered by upper window but presumably open display) and the window on top with a spinning wait icon. Both windows disappear in a blink, no error message, but no display either. Clicking on serial shell works. It shows the first screen on a Linux install with options, for example "Install CentOS, Test media and install, etc." the arrow keys work as expected, but picking an option or letting it time-out clears the screen and then .... nothing, even if I wait for an hour. I've tried three different distros, and even windows 11. The last does not give an option menu, nothing on the serial shell. I think I have tried every combo of options in the add VM diaglog.

The downloaded log just shows a very verbose command to create the vm, and the console messages that the ethernet port is going into promiscuous mode, and out when I power the VM off. I think this all means the VM is created and the CD install iso is booted, but then everything hangs for some reason. I'm probably doing something stupid, but I've googled it every way I can think of but I can't find any similar issues. Help appreciated...