Pool Block Size Question

Status
Not open for further replies.

Cody White

Dabbler
Joined
Dec 5, 2015
Messages
16
All,

I have been following the FreeNAS-11-Nightlies train for some time now and I was in the process of swapping out 2 mirrors in my mirror vdev array to increase my array size and after replacing 2 of the drives I am now seeing "block size: 512B configured, 4096B native"

In my array, I have 15 3TB WD Red drives and I was looking at replacing 4x 500GB drives with 4 more 3TB WD Red's I would have expected to see more of the mismatch given that I already have 15 in my array. Did WD do something different with their latest batches or did I do something wrong?

I did my usual process of removing one of the drives from the mirror, then replacing it with the new drive and then going into Volume Status and use the replace button on the offline drive.

VoGs564.png
 

tvsjr

Guru
Joined
Aug 29, 2015
Messages
959
Sounds like the new drives are 4K sectors, and your pool was created with ashift=9. You can check this with:
Code:
zdb -U /data/zfs/zpool.cache


AFAIK, this isn't something you can change without destroying the pool and recreating it.
 

rs225

Guru
Joined
Jun 28, 2014
Messages
878
It may cause a speed reduction on writes, and isn't considered a serious problem other than that.
 

Ericloewe

Server Wrangler
Moderator
Joined
Feb 15, 2014
Messages
20,091
There's a mitigation for that that's coming, but it's not available yet.
 
Status
Not open for further replies.
Top