• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

More ataidle nightmares!!

Status
Not open for further replies.

globus999

Contributor
Joined
Jun 9, 2011
Messages
105
Setup:

Mobo: 890GPA-UD3H Gigabyte Rev3.1
HDD's: tank1 (raidz1): 4x2Tb EARS WD
tank2 (raidz1): 1TB Samsung, 1Tb Seagate, 2Tb EARS WD, 2Tb Seagate

All HDDs are attache to mobo's controller chips:

North Bridge: AMD 890GX
South Bridge: AMD SB850

Now, I did confirm in the FreeBSD board that BSD 8.2 does support those chips.

Running FN 8.0.1 Beta 4 x64

Sooooo.....

I exported the raidz1's, installed FN from scratch and Auto Imported.
Run scrub, got 0 error in either one (bout 10 hrs of scrubbing in total). So far so good.

Then, I foolishly enable APM (30 min + spin down) and all hell broke loose.

Fist thing that happened was that both raidz1 were unreadable from the GUI. From the CLI, they were still there, but from the GUI nothing but error messages. They disappeared, gone, puf!

So I rebooted, just in case. Well, it did not go well. I got plenty of messages along the lines:

(pass4:ata6:0:0:0): SETFEATURES. ACB: ef 05 00 00 00 40 00 00 00 00 40 00
FREENAS8 kernel: (pass4:ata6:0:0:0): CAM status: CCB request completed with an error
FREENAS8 kernel: Failed to configure APM: No such file or directory

And the xyz... does not support APM
And, of course the oldie but goodie: ata0: timeout waiting for write DRQ

So, I decided to turn APM off. Since I don't have a clue how to do it from CLI (permanently, I mean - I don't want to mock around with FN's DB), I followed the following procedure:

1 - Export one tank
2 - Reboot
3 - GUI autoimports the tank
4 - Quick, disable APM from the GUI

It worked for tank1.

Fine, exported tank2 - rebooted - disabled APM on tank2 and..... tank1 disappears from the GUI!!! WTF!!!!

So, I re-exported tank1 - reboot and now tank2 disappears from the GUI!!!

Now, it is to be noted that by then ALL APM's have been theoretically disabled, however, I still get plenty of nasty messages during boot.

Fine, so I export tank1 and tank2 and reboot.
Plenty of nasty messages but at least now I can see both raidz1 from the GUI.

Well...not so fast. The "fix" does NOT survive reboot!! I checked, both raidz1 are not mounted.

WTF!!!

Not only is ataidle crappily implemented in FN 8.0.1 B4, but its crappines is persistent even after totally disabling APM.

FYI: I updated https://support.freenas.org/ticket/512#comment:4
 

brucec

Cadet
Joined
Oct 23, 2011
Messages
3
Sorry, there was a bug I introduced when adding CAM support to ATAidle: it was always telling the controller to expect a data transfer even for commands which don't transfer data. I fixed it in version 1.6.
 
Status
Not open for further replies.
Top