• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

Marvell Yukon 88E8071 loosing network connection when copying large files

Status
Not open for further replies.
Joined
Jun 23, 2011
Messages
2
Hi everyone!

I got an Acer easyStore H340 which has the Marvell Yukon 88E8071 gigabit network adapter. Running FreeNAS 8 from an USB stick is just fine (because the internal flash only has ~250MB :( ), the network interface gets detected by the correct driver and it works. Until I copy something from my PC to the NAS. For some (varying) seconds, I get transfer rates of ~50MB/s and then suddenly copying stops because the network connection is lost.
I attached display and keyboard to the easyStore and did ifconfig msk0 down && ifconfig msk0 up, then the connection was back up again.
I already tried adding -rxcsum to the interface options like was suggested for the old Marvell drivers for FreeBSD 7.
I also added the following lines to /etc/loader.conf
Code:
hw.nfe.msi_disable = "1"
hw.nfe.msix_disable = "1"
hw.pci.enable_msix=0
hw.pci.enable_msi=0
like suggested in http://forums.freenas.org/showthrea...ng-when-copying-data-to-it&highlight=stalling , although I don't get watchdog messages.

Anybody has an idea, what I could do else?

Thanks in advance
Moritz
 

mhldwards

Cadet
Joined
Jun 24, 2011
Messages
1
I'm having the same problem you are, and unfortunately I've yet to find a solution to get it to work in 1000BaseTX mode.

I have been able to get it to work in 100BaseTX, but that's sadly 10x slower then I'd like. You can do that easily enough by logging in via the console and going to the shell and typing

Code:
ifconfig msk0 media 100BaseTX
ifconfig msk0 down
ifconfig msk0 up


It'll make it work, but I can't get more than 5-6Mbps.

Likewise, if you don't have a gigabit router or switch, it'll auto to 10/100BaseTX and work just fine too.

It seems like most of the fixes are for myk driver, and none of them have helped. FreeNAS8 now uses msk which I believe is FreeBSD's own driver, based on myk.

Sadly, Marvell doesn't have a driver for FreeBSD8, and when I tried loading the old if_myk.ko with the FreeBSD8 version of libmbpool.ko I got a "panic" and it wouldn't boot.

I'm out of ideas, so if you find a better solution, or anyone else has one, I'd love to hear it.
 
Status
Not open for further replies.
Top