FreeNAS 11 on Hyper-V issues thread

Not open for further replies.


Dec 18, 2014
First, I'll describe the issues I have, and then I'll point to several other threads that seem to be related, but they are all unsolved.

I *am* able to use FreeNAS 11 on Hyper-V, but it definitely had some quirks, and there seems to be an intermittent issue when FreeNAS boots up.

My specs:

FreeNAS 11.0-U4
Hyper V Server 2016 (Core, not windows server 2016, aka the free version)
ASRock EP2C602-4L/D16
LSI SAS 9207-8I
6x WD NAS RED drives

First, things that will always trigger a panic during boot. And by panic - its not a nice/normal FreeBSD panic that dumps a core. Rather, it is a stack trace that shows up on the screen, and it just continues forever.

1) A generation 2 vm
2) Enabling SR-IOV on any network adapter

After setting up a normal gen 1 vm without SR-IOV, during boot, during the phase that says:

nvme cam probe device init

This is where the panic, if it occurs, will occur. Sometimes, even after a successful boot, a reboot of the freenas vm will trigger the panic. One time the only way I could avoid it is by rebooting the entire Hyper-V host.

Looking at the trace, it does seem like it may be related to some Hyper-V specific code, as 'vmbus_chan_recv_pkt' and usually shows up. I've seen also 'vfs_mountroot' and 'kdb_trap' also show up.

I have no answers to this at this time, which is unfortunate, since not having a reliable freenas boot up is very frustrating. But, since I'm sorta working, I'll deal with it. I need certain features of Hyper-V for my guests, namely Remote FX.

I'll gladly send my entire freenas.vhd file to any FreeNAS dev that will care to reproduce/diagnose this issue.

I also downloaded FreeBSD-11.0 (the .vhd file) from and it worked without a problem.

Here are other links I've found that seem to be the same problem <- this link had a good mitigation, which seemed to help a bit. (Adding set"50000" to grub bootloader)

Possibly related bugs: <-- this one has a hint that I'll try next - to disable guest services on the vm
Last edited by a moderator:


Server Wrangler
Feb 15, 2014
The nvme driver currently has some extremely weird behavior with specific devices that is being debugged. Use older standards for now.

I also downloaded FreeBSD-11.0 (the .vhd file) from and it worked without a problem.
Can you try 11.1?

2) Enabling SR-IOV on any network adapter
On the host, you mean?
Not open for further replies.