Dataset Permissions not updating for NFS client

Not open for further replies.


Jun 2, 2018
Hey all, this is my first extensive experience with FreeNAS and my first extensive work with NFS. I've worked through the initial "oh, my UID/GID doesn't match" issue when trying to get permissions right, but now I'm having something a bit more... odd..

I have a volume, "vol_z201", I have a dataset inside that volume, "media", I also have a folder I created via "mkdir" on the FreeNAS side inside "vol_z201" called "test". I'm sharing the "vol_z201" volume out using NFS (ONLY). I was working through getting my service account setup for transferring some data over and noticed that my permission changes to the dataset ("media") on the server weren't updating on the client side. They show correctly on the FreeNAS side, but the client side doesn't seem to update when I perform chmod/chown operations or update permissions through the FreeNAS GUI. I'm sure this is an easy issue, but nothing I can think of to fix it is working.

I've tried
* Changing the permissions (group ownership, user ownership, or rwx permissions) in FreeNAS to see if something was stuck on the client
* Remounting the NFS device on the client
* Restarting the client
* Restarting FreeNAS

I have noticed that when I mount the drive on a new client, which has never had the device mounted, it shows the incorrect permissions as well so I don't believe this is client-side caching?

Here's the setup on the FreeNAS device (FreeNAS-11.1-U5):

Here's the setup on the client (CentOS Linux release 7.3.1611 (Core)) :

When I make these same changes using chmod on the folder "test" it is updating on the clients immediately as I expect.

Is there something additional I need to do on the FreeNAS side when updating permissions on datasets inside of a volume that is shared?
Not open for further replies.