Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Can't update from 11.1 U6 to 11.2

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

sobmalag

Neophyte
Joined
Nov 28, 2017
Messages
4
I updated from 11.1 U6 to 11.2-Release from GUI, after reboot it hangs at normal booting...I reverted back to 11.1 U6 and tried to update from usb but it hangs at Booting...
Motherboard is Asrock Q1900-ITX, BIOS up to date.
Has anyone else this issue or any idea how to solve it?
 

Attachments

D

dlavigne

Guest
This looks like the issue:

Code:
freenas-boot  14.4G  7.16G  7.22G         -      -    49%  1.00x  DEGRADED  -


Try a fresh install of U6 on a new stick, restore your config, then try the upgrade again.
 

nasmaniac87

Newbie
Joined
Feb 6, 2019
Messages
3
Issue solved
Hi, I have very similar configuration like U (Asrock Q1900 itx). I can not install version 11.2. What are your BIOS settings? I'm doing a completely clean installation on the SSd drive. Its stop at 'booting' or AHCI error. I think I have used all the combinations of settings.... do you install from usb memory? what program do you use to create the installation boot disk?
 

Xirtari

Newbie
Joined
Nov 24, 2014
Messages
1
Hi, same problem as OP with motherboard Asrock q1900b-ITX and usb stick as boot drive. Upgraded via GUI from 11.1 U7 to 11.2 but it hangs on boot. Via the boot manager I can select 11.1 U7 and boot up normally. It does look like a bootloader issue considering the migration to the Freebsd bootloader... Any suggestions? Is it solved by a fresh install?

Thanks you all for any help!
 

Mr T

Newbie
Joined
Jun 28, 2015
Messages
1
Hi, same problem as OP with motherboard Asrock q1900b-ITX and usb stick as boot drive. Upgraded via GUI from 11.1 U7 to 11.2 but it hangs on boot. Via the boot manager I can select 11.1 U7 and boot up normally. It does look like a bootloader issue considering the migration to the Freebsd bootloader... Any suggestions? Is it solved by a fresh install?

Thanks you all for any help!
I had the same upgrade problem with my little ASRock Q1900-ITX system, ie hanging on trying to boot into 11.2. Fresh install didn't help. After reading the discussion at https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230172, I set a couple of bootloader variables in the FreeNAS 11.1-U7 Tunables list, setting variable kern.vty to value vt and variable hw.vga.acpi_ignore_no_vga to value 1. My FreeNAS 11.1-U7 then proceeded to upgrade normally to 11.2-U8 (via the browser interface), and from there upgraded straight to 12.0-U2.
 
Top