Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Cannot create Pool on ada0

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

OskOskOsk

Newbie
Joined
Apr 24, 2021
Messages
1
I wona use my old ssd drive where Windows is installed and use it in my FreeNas server. In Create Pool three aren't option to use this drive. How can I fix it? Below is pool status and fdisk outcome.

Code:
root@truenas[~]# zpool status
  pool: Soft_Pool
state: ONLINE
config:

        NAME                                          STATE     READ WRITE CKSUM
        Soft_Pool                                     ONLINE       0     0     0
          gptid/6b6d8bd0-9f64-11eb-ae40-2006101a1cbf  ONLINE       0     0     0

errors: No known data errors

  pool: boot-pool
state: ONLINE
  scan: scrub repaired 0B in 00:00:09 with 0 errors on Fri Apr 23 03:45:09 2021
config:

        NAME        STATE     READ WRITE CKSUM
        boot-pool   ONLINE       0     0     0
          ada0p2    ONLINE       0     0     0

errors: No known data errors


Code:
root@truenas[~]# fdisk ada0
******* Working on device /dev/ada0 *******
parameters extracted from in-core disklabel are:
cylinders=465141 heads=16 sectors/track=63 (1008 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=465141 heads=16 sectors/track=63 (1008 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 238 (0xee),(EFI GPT)
    start 1, size 468862127 (228936 Meg), flag 0
        beg: cyl 0/ head 0/ sector 2;
        end: cyl 1023/ head 255/ sector 63
The data for partition 2 is:
<UNUSED>
The data for partition 3 is:
<UNUSED>
The data for partition 4 is:
<UNUSED>
root@truenas[~]#
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
17,231
ada0 is clearly your boot pool, not a Windows disk.
 
Top