Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.
Installing Ubiquiti UniFi Controller in a jail

Installing Ubiquiti UniFi Controller in a jail

Only thing i would say is that if you are using iocage as recommended the command to access the jail would be "iocage console <jailname>" Other than that Great post!
I got errors when I ran "make install clean" but I had success using "make deinstall install clean"
simple and works great, thanks!
Great guide, I ran into a small problem with changing MongoDB versions, and here's my notes...
When upgrading to the latest version (currently 5.9.29) you may require an upgrade of MongoDB from 3.4 -> 3.6. Before starting the upgrade make sure to set the compatibility version in the database to 3.4 (see: https://docs.mongodb.com/manual/release-notes/3.6-upgrade-standalone/).
Also, make sure to connect to the UniFi mongoDB (e.g. mongo --port 27117), just in case there is also a default mongo instance running.
failed the first time, tried installing the pkg packages listed and binary completed the 2nd attempt
seems like that could just be added as a step instead of being out of order
Thanks! Just note that "make reinstall clean" may no longer work (see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=224244)

If you run into this problem then after stopping the unifi service (and inside the unifi5 ports directory) run the following:

- make package
- pkg install -f work/pkg/package-name

Replacing "package-name" with whatever is the correct name, e.g.) "unifi5-5.8.24.txz"
Easy to follow along and most importantly, it worked!
Great help!
Straightforward, well documented and explained.
Tons of people have asked for this in ubnt forums. Did not know it was this simple.
easy to understand and straightforward.
Awesome and excellent that you included how to update as well!
Perfect guide for installing Unifi Controller on my FreeNAS server
Had to register to thank you for this quick guide. Saved me a couple hours of work to figure this out on my own! Thanks!
Great guide.Made upgrading my UniFi network easy. Thanks so much for the time and effort put into this.
Excellent
This worked great on FreeNAS 11.0-U2
Top