Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Limit Simultanous Replication Tasks?

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Metheos

Neophyte
Joined
Feb 1, 2017
Messages
8
I recently upgraded to 11.3-U3.1 from 11.1. I've been fiddling to get my legacy snapshot and replication tasks working the way they were before, but I can't quite figure it out.

I have snapshot tasks for my zvols that run around the same time. I've got that working now, so the snapshots get created as expected. I also have a replication task for each zvol that is running every 10 minutes looking for new snapshots using the "also include naming schema". At first I tried the new way of having the replication tasks linked to the snapshots, but it seemed like that was causing the snapshots to queue or something? I was only getting a portion of the snapshots job completing before their scheduled time windows ran out.

This setup is working with one snag, it runs all the replications at the same time. This kinda bogs down my performance. In 11.1 it would only let 1 transfer go at a time, so that was ideal.

Any way to make 11.3-U3.1 act that way? or just limit the replication tasks to 1 or 2 at a time?
 

Glorious1

Neophyte Sage
Joined
Nov 23, 2014
Messages
1,088
That's disconcerting. I guess I'll stick with 11.3-U2.1 until someone can answer this.
 

mgittelman

Senior Member
Joined
Dec 8, 2017
Messages
409
I've noticed the same thing since 11.3. Doesn't seem to matter if the tasks are SSH or SSH + Netcat. I'm not sure if would make a difference, but have you tried setting the tasks to legacy?
 
Top