Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

DrKK's Definitive Guide to Installing OwnCloud in FreeNAS (or FreeBSD)

Status
Not open for further replies.

rldoose

Junior Member
Joined
Apr 16, 2016
Messages
17
So I did a stupid thing and nuked the contents of:
/usr/local/www/owncloud/

Is there anyway to repair this? No snapshots, no backups......

Really kicking myself..... :(
 

rldoose

Junior Member
Joined
Apr 16, 2016
Messages
17
So a few days ago I followed DrKK's guide successfully, and even posted how great it was. But I had to start over for about the 47th time..... Now, apparently after an upgrade, things have gone to doo doo (I really want to curse here....) and I can no longer install lighttpd....

Getting "pkg: No packages available to install matching 'lighttpd' have been found in the repositories" Attempting to follow the Optional Step 4 in the guide, I learn that "/usr/local/etc/pkg.conf" is now deprecated in favor of "/etc/pkg/FreeBSD.conf" PER: https://forums.freebsd.org/threads/43506/

But FreeBSD.conf looks fine, and I get:
FreeBSD repository is up-to-date.
All repositories are up-to-date.

But attempting to install lighttpd still just gets me:
pkg: No packages available to install matching 'lighttpd' have been found in the repositories.

Guidance on how to fix this wold be greatly appreciated!
 

Aaron Siemieniec

Junior Member
Joined
Apr 13, 2015
Messages
22

Attachments

Last edited:

lneib

Junior Member
Joined
Nov 29, 2014
Messages
16
I have been running OwnCloud for a while now based on Dr. KK's tutorial and video. we started with 7.2 and then went to OwnCloud 8.0.4. Over the weekend I updated Owncloud to Version 8.2.1 and noticed that my PHP was still at 5.4.45 and I know 5.6.x is not available. Has anyone upgraded PHP and does it "break" anything? I know there is always a risk but I know 5.4.x is no longer supported and I want to upgrade.

Second is there a way to back up the current PHP install in case I need to roll back?

BTW: my OwnCloud upgrade went smooth as silk except for the environment variable and I figured that out based on some of the posts in this thread. Kudos to all who contribute.

Thanks in advance
 

Kevin Horton

Neophyte Sage
Joined
Dec 2, 2015
Messages
692
Why not take a snapshot of the jail? If the upgrade goes badly you could roll the jail back to the snapshot.
 

adrianwi

Neophyte Sage
Joined
Oct 15, 2013
Messages
1,180
Exactly what I do before any ownCloud upgrade. Also consider your database and file locations if they are outside the jail structure.
 

SylvainRP

Newbie
Joined
Aug 2, 2016
Messages
2
hellos
I block I have followed the tutorial and demarage of owncloud ca makes me " SQLSTATE [ HY000 ] [ 2002 ] No such file or directory "
help me please:(:(:(
excuse me for the English I have a can of evil.:)
 

DrKK

FreeNAS Generalissimo
Joined
Oct 15, 2013
Messages
3,630
hellos
I block I have followed the tutorial and demarage of owncloud ca makes me " SQLSTATE [ HY000 ] [ 2002 ] No such file or directory "
help me please:(:(:(
excuse me for the English I have a can of evil.:)
Sylvan:


Je peux parler francais. Si tu voudrais reposer encore la question en francais? Ton anglais...c'est....difficile a comprendre. Si le probleme est quelque chose qui s'agit de SQL, on imagine qu'on ne peut pas t'aider beaucoup....problemes de SQL ne sont pas problemes de OwnCloud soi-meme :(

En revanche, si tu veux nous rendre visite au canal IRC, tu devrais trouver quelque monde qui peut parler francais, et recevoir tes reponses sans attendre.
 

SylvainRP

Newbie
Joined
Aug 2, 2016
Messages
2
bonjours
Je bloque j'ai suivi le tutoriel et au demarage de owncloud sur la page ou on créé le compte admin ca me fait une erreur " SQLSTATE [ HY000 ] [ 2002 ] Aucun fichier ou répertoire"
Aidez-moi s'il vous plaît:(:(:(
Quel qu un a une solution ?
 

THX

Member
Joined
Dec 6, 2013
Messages
28
I installed with the youtube howto. I got owncloud up and running. Everything seems to work reagarding the web interface. After installing Contact, Calender and Tasks, I was hoping webDAV would be working out of the box. From my mobile with DAVdroid I get an error like "no caldav nor carddav service found".
Do I need to configure webDAV module in lighty? If yes I don't know how. I uncommented mod_webdav in modules.conf and added this to lighttpd.conf (got that from the lighhtpd website)
Code:
# WebDAV Support?
$HTTP["url"] =~ "^/dav($|/)" {
  webdav.activate = "enable"
  webdav.is-readonly = "enable"
  webdav.sqlite-db-name = "/var/run/lighttpd/lighttpd.webdav_lock.db"
}

But Lighty is not starting, something is wrong.
Code:
root@ownCloud:/usr/local/etc/lighttpd # service lighttpd onestart
Starting lighttpd.
Duplicate config variable in conditional 1 global/HTTPurl=~^/dav($|/): webdav.activate
2016-10-16 19:38:31: (configfile.c.1078) source: /usr/local/etc/lighttpd/lighttpd.conf line: 503 pos: 23 parser failed somehow near here: (EOL)
/usr/local/etc/rc.d/lighttpd: WARNING: failed to start lighttpd
root@ownCloud:/usr/local/etc/lighttpd #

Maybe my whole approach is wrong, need some advice, please.
 

Osiris

Member
Joined
Aug 15, 2013
Messages
149
Excellent guide. Only, the filecaps seem outdated. I want to sync 20GB-files.
 

Cheejyg

Member
Joined
Dec 11, 2016
Messages
31
Unfortunately this did not help. The phpinfo is also getting the right values from the php ini in the master value column.
Could it be "overridden" by something?
just a quick question if you don't mind, how did you get your phpinfo.php to show? mine keeps redirecting me to /apps/files/
 
Status
Not open for further replies.
Top