(408) 943-4100               V   Commercial Support

Web Console Log

  2 minute read.

Last Modified 2021-03-11 10:56 EST

A web console log can help to diagnose problems with the user interface. This document explains how to save the web console log from different browsers. The log can then be added to a TrueNAS issue for debugging.

Firefox

Open the web console by clicking (Menu) > Web Developer > Web Console or by pressing Ctrl-Shift-K.

In the upper right, set Persist Logs. Click (More) > Settings. In the Web Console section, set Enable timestamps.

For versions 78 and later, click (Settings) in the Web Console area and set Enable timestamps and Persist Logs. Click the Console tab or press Ctrl-Shift-K to switch to the console window.

Leave the console open and perform the action that encounters problems. Right-click in the console window and select Export visible messages to clipboard. Open an editor, paste the clipboard contents, and save to a new console.log file.

After saving the file, go back to the console with (Menu) > Web Developer > Web Console or by pressing Ctrl-Shift-K. Find and unset Persist Logs.

Chrome

Open the console by clicking (Options) > More Tools > Developer tools or by pressing Ctrl-Shift-I.

Click (Settings) and set Preserve log.

Click (Options) > Settings > Preferences. In the Console section, set Show timestamps. Close the Preferences window.

Leave the console open and perform the action that encounters problems. Right-click in the console window. Choose Save as… and save to a file called console.log.

After saving the file, go back to the console with (Options) > More Tools > Developer tools or by pressing Ctrl-Shift-I. Click (Settings) and unset Preserve log.

Attaching a Console Log File to a Report

Go to the iXsystems Bug Tracker. Locate an existing ticket or create a new one reporting the problem. Attach the console log file to the ticket by dragging it to the Document Vault.