Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Transmission plugin losing torrents list after restart.

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Whattteva

Guru
Joined
Mar 5, 2013
Messages
750
I have a strange problem. My transmission plugin keeps losing a list of its torrents whenever the daemon is restarted.
Permissions are all correct and it can read/write just fine when it detects a new torrent file in the watch directory, downloads the file to completion, and even seeds it normally after. Everything basically works normally until the service or the jail is restarted. Then it will lose all its torrents and I will have to rename all the torrent.added files back to .torrents for it to pick up the torrents again.

I've noticed a few other people have this issue over at the transmission forums, but none of the suggestions worked.
Anyone else has come across this issue? Any help is much appreciated.
 

mistermanko

Patron
Joined
Jan 27, 2020
Messages
419
Is any other service than transmission claiming ownership of the directory in which the .torrent files reside?
 

Whattteva

Guru
Joined
Mar 5, 2013
Messages
750
There shouldn't be. The only other service running in it is OpenVPN that connects to a NordVPN service in another directory.
Transmission runs out of
Code:
/usr/local/etc/transmission/home/
while OpenVPN runs out of
Code:
/usr/local/etc/openvpn/


I don't use any mount points for the jail and transmission has exclusive access to the directories as this is intended to run all the time so I can get a lot of seed ratio. It's kind of like the reason why I'm stumped because it's a rather simple bare-bones setup that should be really straight-forward.
 
Top